Results 1 to 3 of 3

Thread: Fuel issues

  1. #1
    Senior Member Carroll Shelby Rsmith350's Avatar
    Join Date
    Dec 2007
    Location
    Conroe, TX
    Posts
    1,040
    Blog Entries
    1

    Angry Fuel issues

    Brand new fuel pump. Started after I put it in. I drained the tank before installation. When I hit the fuel I donít here the pump and it just spins. Checked fuses and connection at the back seat. Any ideas? Just bad pump?!
    " Racing makes crack addiction look like a mild craving for something salty"

  2. #2
    Senior Member Carroll Shelby
    Join Date
    May 2013
    Location
    Arlington, TX
    Posts
    1,017
    I've had issues with that harness connector(8 pins IIRC) by the tank, have you checked voltage there? Seems like aftermarket pumps pull too many amps for that connector and it starts to get sketchy, I remember slightly bending a pin and cleaning it up to do a temp fix on my issue, this is assuming a LS car.
    Tyler Gardner
    CMC #13 2015-2017
    SM #013 2018
    www.dfwmustangs.net

  3. #3
    Junior Member Rookie
    Join Date
    May 2009
    Location
    Eureka, Il
    Posts
    26
    Check the fuel pump ground. If it is a GM the fuel pump ground is right at the floor to the left of the drivers seat. It is a very weak little ring with a self tapping bolt.
    Bob
    Bob Denton
    CMC #67
    Great Lakes Region

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •